K3 1000 bogged out and now won't start - Suzuki Forums

Suzuki Forums: K3 1000 bogged out and now won't start - Suzuki Forums

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

K3 1000 bogged out and now won't start Rate Topic: -----

#1 User is offline   Random603 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 1
  • Joined: 20-July 20
  • LocationNew Hampshire
  • Bike:K3 gsxr 1000

Posted 20 July 2020 - 05:35 PM

ve searched all over and can't figure out what the problem could be. I jumped on my bike the other day,started right up, no problems and went for a ride into town. Along the way I got stuck behind a slow poke driver for most of my trip. Got to the store went in,came out the bike started up just fine and I went on my way. I get a lil bit down the road and it starts to sputter and act like it was loaded up or flooding the plugs. I tried to give it some throttle to maybe clear it out and it just loses power and barely runs. Eventually it died and wouldn't restart. So I tow it home and figure its a fouled plug. I could smell gas while trying to start it,and it will turn over and start but not stay running. I replaced the plugs (they needed to be replaced) and when I turn it over it still does the same thing. When I turn the key I can hear the fuel pump prime and stop and then start it but then dies. I can get it to run for about 10 seconds if I mess with the throttle but it runs like shit and then dies. When I spray starter fluid down into the intakes it will fire up but I can't keep it running and it immediately dies. Im at a total loss and beyond frustrated. Any help is greatly appreciated.
0

Remove Advertisements Sponsored Links

    Suzuki-Forums.net



Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users